Strumenti Utente

Strumenti Sito


capitolo_7

7. Usare il foglio elettronico

7.1 Che cos'è un foglio elettronico

Un foglio elettronico o foglio di calcolo è una tabella che contiene dei dati che possono essere elaborati in maniera automatica. La tabella è composta da celle la cui posizione è individuata da una colonna, indicata con una lettera maiuscola, e una riga, indicata con un numero (ad esempio la cella A1 è quella più in alto a sinistra, la cella B1 è quella alla sua destra, e così via). Nelle celle vengono iseriti dei dati o delle formule che elaborano questi dati.

Laboratorio

Selezionare le celle

  • per spostarmi in una cella posso cliccarci sopra o indicare le coordinate nel navigatore delle celle (in alto a sinistra)
  • per selezionare un gruppo di celle (intervallo) usare il mouse (cliccare e trascninare) o indicare la selezione separando la cella in alto a sinistra e quella in basso a destra con il simbolo : (ad esempio A1:C3 seleziona le nove celle in alto a sinistra)
  • per aggiungere una cella “spaiata” a una selezione separarla col simbolo ; (ad esempio (A1:C3;A5) seleziona le prime nove celle in alto a sinistra e la cella A5

Inserire valori nelle celle

  • per inserire un valore in una cella selezionarla (il bordo viene evidenziato in nero) e digitare il valore; per confermare premere invio o una delle frecce
  • nelle celle i numeri sono allineati a destra, il testo a sinistra
  • una stringa è una sequenza di numeri e lettere (quando in una cella inserisco del testo ho inserito una stringa)

Modificare le celle

  • per modificare il contenuto di una cella posso:
    • selezionarla e premere il tasto F2
    • fare doppio click sulla cella
    • usare la barra della formula (accanto al navigatore delle celle subito sopra la tabella)
  • per cancellare il valore di una cella o di un gruppo di celle selezionarle e premere il tasto canc

Formule e funzioni

  • per inserire una formula in una cella devo cominciare col carattere =
  • le formule possono contenere delle funzioni indicate da una parola chiave e da una coppia di parentesi tonde; il nome delle funzioni può comprendere il simbolo .
  • il nome delle funzioni e le coordinate delle celle sono spesso indicate in maiscolo ma si può usare anche il minuscolo
  • i parametri delle funzioni vanno indicati tra le parentesi tonde separati dal simbolo ; (quando un parametro è opzionale è indicato tra parentesi quadre)
  • riferimenti: è possibile fare riferimento al valore contenuto in una cella indicando le coordinate della cella (ad esempio digitando B4 in una formula viene utilizzato il valore contenuto nella cella di coordinate B4); quando si modifica una formula ogni riferimento è indicato con un colore che viene usato per evidenziare la cella corrispondente
  • intellisense, completamento automatico o suggerimento che compare quando si digita una funzione in una cella (nel tooltip una breve spiegazione della funzione); per selezionare una voce usare le frecce e premere il tasto TAB

Generare numeri casuali

  • in matematica (non in excel) per indicare un intervallo si usano le parentesi: quadre, per indicare che l'estremo è compreso e tonde, per indicare che l'estremo è escluso. Ad esempio [0;1) è l'intervallo tra zero (compreso) e uno (escluso)
  • la funzione CASUALE() genera un numero a caso tra zero (incluso) e uno (escluso)
  • per generare un numero tra 0 e 3 usare la formula CASUALE()*3
  • per generare un numero tra 1 e 3 usare la formula CASUALE()*2+1
  • per generare un numero tra a e b usare la formula CASUALE()*(b-a)+a
  • la funzione CASUALE.TRA(a;b) genera un numero intero a caso tra a e b (compresi)
  • premendo il tasto F9 vengono ricalcolate tutte le formule del foglio e, di conseguenza, vengono ri-generati (aggiornati) i numeri casuali

Contare le celle

  • la funzione CONTA.VALORI(intervallo) conta il numero di celle non vuote nell'intervallo
  • la funzione CONTA.NUMERI(intervallo) conta il numero di celle che contengono dei numeri nell'intervallo

Formattazione

  • per applicare una formattazione a una cella o a un gruppo di celle occorre prima selezionarle
  • con il tasto CTRL-1 si apre la finestra Formato celle dove è possibile modificare la formattazione
  • per cancellare la formattazione dalla tab Home scegliere cancella|cancella formati
  • per modificare il numero di decimali visualizzati dalla tab Home sezione Numeri scegliere i tasti aumenta/diminuisci decimali (NB non stiamo cambiando la precisione del numero ma solo il modo in cui viene visualizzato)
  • per formattare un numero mettendo in evidenza che si tratta di una valuta (euro, dollari, ecc.) usare il tasto Formato numeri contabilità nella tab Home sezione Numeri
  • per formattare un numero come valore percentuale utilizzare il tasto apposito nella tab Home sezione Numeri. Il numero verrà interpretato come valore percentuale diviso 100 (ad es. 15% verrà interpretato come 0,15)

Gestione tabella

  • per inserire una riga click destro sulla riga sotto e inserisci
  • per aumentare la larghezza di una cella cliccare e trascinare il separatore tra le due lettere che indicano le colonne
  • per adattare automaticamente la larghezza delle celle fare doppio click sul separatore tra le due lettere che indicano le colonne
  • per ordinare delle celle selezionarle e dalla tab Home scegliere Ordina e filtra| Ordina dalla A alla Z
  • per impedire che la prima riga scompaia mentre si scorre la tabella verso il basso dalla tab Visualizza scegliere Blocca Riquadri|Blocca riga superiore (in modo simile è possibile bloccare la prima colonna o entrambe)

Riempire automaticamente le celle

  • per riempire automaticamente delle celle in base al contenuto di una selezione, cliccare e trascinare il quadratino nero in basso a destra nella selezione. Le celle vengono riempite in maniera automatica completando una serie di numeri o copiando le formule (ma adattando i riferimenti alle celle contenuti nelle formule alle righe/colonne in cui vengono copiate)

Creare grafici

  • i grafici non vengono disegnati a mano ma sono generati utilizzando i dati contenuti nelle celle
  • dalla tab Inserisci nella sezione Grafici scegliere un tipo di grafico (ad esempio istogramma)
  • selezionare il grafico (per ora vuoto) e dalla tab Inserisci scegliere Seleziona dati per indicare quali celle utilizzare per tracciare il grafico (serie di dati)
  • cliccare su Aggiungi, indicare il nome della serie (o selezionare una cella che contiene il nome) poi selezionare un intervallo con i valori da utilizzare per il grafico (per selezionare dalla tabella usare il pulsante a destra con la freccia rossa)
  • selezionare Modifica da Etichetta dati orizzontali per selezionare l'intervallo con i nomi da usare per le colonne dell'istogramma
  • per creare rapidamente un grafico selezionare nel foglio le celle che contengono i dati da usare e dalla tab Inserisci nella sezione Grafici scegliere un tipo di grafico; il programma seleziona automaticamente la serie di dati e le etichette; se il risultato non è soddisfacente è possibile modificare il grafico con gli strumenti disponibili nella barra multifunzione (Progettazione, Layout, ecc.) o nel menu contestuale

Formattazione condizionale

  • è possibile modificare la formattazione in funzione del contenuto delle celle. Questo permette di evidenziare alcuni valori secondo determinati criteri
  • per applicare la formattazione condizionare dalla tab Home sezione Stili scegliere Formattazione condizionale; indicare un criterio e selezionare uno stile

Riferimenti assoluti

  • quando si copia una formula (o si usa il riempimento automatico) i riferimenti contenuti nella formula vengono adattati cambiando riga o colonna. Se si vuole che un riferimento (riga o colonna) non venga cambiato ma rimanga lo stesso in tutte le formule bisogna usare il simbolo $ nella formula che verrà copiata. Il dollaro può essere inserito:
    • prima della colonna per bloccare il riferimento alla colonna (ad es. $A2)
    • prima della riga per bloccare il riferimento alla riga (ad es. C$1)
    • prima di riga e colonna per bloccare il riferimento a riga e colonna e usare la stessa cella in tutte le formule (ad es. $D$1)

Funzioni logiche

  • con la funzione SE è possibile indicare due valori per il contenuto di una cella e selezionare uno dei due in base a una condizone; la sintassi è SE(condizione; valore 1; valore 2): la cella conterrà il valore 1 se la condizione è vera e il valore 2 se è falsa
  • la funzione E restituisce il valore logico VERO se tutti i suoi parametri - che sono test logici - valgono VERO; se anche uno soltanto è FALSO il risultato della funzione è FALSO; la sintassi è E(test1; test2; test3; …)
  • la funzione O restituisce il valore logico VERO se almeno uno dei suoi parametri - che sono test logici - vale VERO; la sintassi è O(test1; test2; test3; …)
  • con la funzione CONTA.SE è possibile contare i valori che soddisfano un criterio in un dato intervallo; la sintassi è ''CONTA.SE(intervallo; criterio); i criteri possono essere numeri, riferimenti a celle o espressioni che usano una sintassi particolare (vedere la guida in linea di Excel)

Torna all'indice.

This website uses cookies for visitor traffic analysis. By using the website, you agree with storing the cookies on your computer.More information
capitolo_7.txt · Ultima modifica: 2016/01/10 18:53 (modifica esterna)